Loading ...

DMI指标配合阶段高低价的量化交易策略

Author: mindrainbow, Created: 2019-08-05 13:56:07, Updated: 2019-08-06 10:24:59

DMI指标

趋势交易者的主要目标是在趋势方向上买入或卖出资产。仅从资产价格中读取方向信号可能很困难并且经常会产生误导,因为价格通常在两个方向上波动并且在低波动率和高波动率之间变化特征。

定向运动指示器(也称为定向运动指标或DMI)是评估价格方向和强度的有用工具。它由J. Welles Wilder于1978年创建,他也创造了流行的相对强弱指数(RSI)。DMI对趋势交易策略特别有用,因为它区分强弱趋势,允许交易者只进入具有真实动量交易标的。DMI适用于所有时间范围,可应用于任何交易标的(股票,共同基金,交易所交易基金,期货,商品,数字货币和法定货币)。

虽然它的计算有些复杂,但DMI会告诉您何时做多或做空。在这里,我们将详细介绍如何分析DMI指标,并向您展示它可以揭示哪些信息,以帮助您获得更好的利润。

DMI趋势线

DMI是给定时期内范围扩展的移动平均值(默认值为14天)。正向移动指标(+DMI)衡量价格向上移动的强度;负向移动指标(-DMI)衡量价格向下移动的强度。这两条线反映了牛与熊的相应强度。

每个DMI由一条单独的线表示。首先,看看两条DMI线中哪条线位于顶部。一些短线交易者称这条顶部的线是主DMI线。主DMI更强,更有可能预测价格方向。为了让买家和卖家改变主导地位,两条线必须金叉或者死叉。

当底部的DMI穿过顶部的主DMI时发生交叉。交叉似乎是一个明显的多头/空头信号,但许多短期交易者将等待其他指标确认进入或退出信号,以增加他们进行盈利的机会。DMI线的交叉通常是不可靠的,因为它们在波动率低时经常给出错误信号,在波动率高时经常给出滞后信号。将交叉视为潜在方向变化的第一个迹象。加上本策略提到的配合阶段高低价以辅助验证,运用DMI策略进行交易会大大提高胜率。

在发明者量化平台配合阶段高低价部署DMI策略

策略名称: 动向指数(DMI)与高低点策略

时间周期: 5分钟

支持: 商品期货,数字货币现货/期货

img img

主图:

AMA1指标,公式:AMA1^^EMA(DMA(CLOSE,CQ1),2);
AMA2指标,公式:AMA2^^EMA(DMA(CLOSE,CQ2),2);

My语言源码:

DIR1:=ABS(CLOSE-REF(CLOSE,N));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),N);
ER1:=DIR1/VIR1;
CS1:=ER1*(2/(N1+1)-2/(N2+1))+2/(N2+1);
CQ1:=CS1*CS1;
AMA1^^EMA(DMA(CLOSE,CQ1),2);

DIR2:=ABS(CLOSE-REF(CLOSE,M));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),M);
ER2:=DIR2/VIR2;
CS2:=ER2*(2/(M1+1)-2/(M2+1))+2/(M2+1);
CQ2:=CS2*CS2;
AMA2^^EMA(DMA(CLOSE,CQ2),2);

cq22:CQ2;
aa:DMA(CLOSE,CQ2);

BKVOL=0  AND  REF(AMA1,1)<REF(AMA2,1)  AND  AMA2<AMA1,BPK;
SKVOL=0  AND  REF(AMA1,1)>REF(AMA2,1)  AND  AMA2>AMA1,SPK;

策略源码,请查看:https://www.fmz.com/strategy/128418


More